
Ansys Lab — 2D Stress Analysis 

Purpose 

• Create free mesh with size control 
• Use PLANE82 8-node quadrilateral element 
• Specify symmetric constraint equation 
• View stress distribution in 2D problems 
 

Lab exercise 

Analyze a square plate (edge length = 4 in) with a hole at the center (radius =1 in) and 
four corner bolt holes (diameter = 0.25 in). The plate is subjected to pressure load on the 
two opposite sides and is bolted through the bolt holes. Taking advantage of symmetry a 
one quadrant model is shown in the figure. The appropriate boundary conditions along 
symmetric sides are also shown in the figure. 
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Elastic modulus = 30E6 psi Poison ratio = 0.27 Thickness of plate = 0.1 in 

Initial Set Up 

1. Enter the ANSYS program by using the launcher  
 
• Click ANSYS from the launcher menu. 
• Type a job name in the Initial jobname entry field of the dialog box. 



• Specify the working directory  
• Pick Run to apply the information 

2. Specify a title for the problem. 
 
• ANSYS Utility Menu > File 
• Change Title > Enter new title [Plate Model] > OK 

3. Set up the graphics area. 
• Workplane 
• WP Settings >  Grid and Triad 

Snap Incr[ 0.125 ] 
Spacing[ 0.125 ] 
Minimum[ -2 ] 
Maximum[ 2 ] > OK 

•Workplane > Display Working Plane 
•PlotCtrls >  View Settings > Magnification > DVAL 

User Specified [ 2.5 ] > OK 

 

Preprocessing 

1. Begin the solid model by creating one 2 x 2 square. 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas- Rectangle > By 2 Corners  

[ WP = (0, 0) ] 
[ WP = (-2, 2) ] 

> OK 

2. Create the large circle at the corner of the square 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas-  Circle > Solid Circle  

[ WP = (0, 0) ] 
[ r = 1 ] 

> OK 

3. Create the bolt hole circle. 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas-  Circle > Solid Circle 

[ WP = (-1.5, 1.5) ] 
[ r = 0.125 ] 

> OK 

4. Boolean operation: subtract two circles from the main area to form the  model. 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Operate 

-Booleans- Subtract > Areas 



[Square area ] 
 
[Large right circle] 
[Small left circle] 

> OK 
• ANSYS Toolbar > SAVE_DB 

5. Define the element type (PLANE82, the 2-D, 8 node, structural solid, plate thickness, and material 
properties. 
• ANSYS Main Menu 
• Preprocessor > Element Type > Add/Edit/Delete... 

Add... > Structural Solid > [ Quad 8node 82] > OK 
  Options... > PLANE82 element type options > k3 [Plane strs w/thk ] > OK 
                   >Close 
• Preprocessor > real Constants...>Add/Edit/Delete>Add...>OK>RealConstant for PLANE82> 
 THK [ 0.1 ] > OK > Close 
• Preprocessor > Material Props > Material models... > Structural > Linear > Elastic > Isotropic 

EX [ 30e6 ] PRXY[ 0.27 ] 
• ANSYS Toolbar > SAVE_DB 

6. Specify an element size and mesh the solid model. 
• ANSYS Main Menu 
• Preprocessor > -Meshing- Size Control 

-Manual Size- > -Global- Size...> SIZE [ 0.1 ] 
• Preprocessor > -Meshing- Mesh 

-Areas-  Free > Pick All 

 

Solution 

1. Apply displacement constraints around the small hole and symmetry boundary conditions 

• ANSYS Utility Menu  
• PlotCtrls > Numbering > Plot Numbering Controls > KP > On > OK  
• Plot > Lines 
• ANSYS Main Menu 

• Solution > -Define Loads- Apply 
-Structural- Displacements > On Keypoints 

[The four keypoints around the small hole.] 
 

• Apply U, ROT, on KPs > Lab2 [All DOF] > KEXPND > Yes > OK 
• Solution > -Define Loads- Apply 
-Structural- Displacements > -Symmetry B.C.- > On Lines 

[The bottom line of the model.] 

[The right vertical line of the model.] > OK 
 
2. Apply displacement constraints around the small hole and symmetry boundary conditions 
 
• ANSYS Main Menu 



 • Solution > -Loads- Apply 
-Structural- Pressure > On Lines  

[The left vertical line where pressure forces applied] 

 
• Apply PRES on Lines > VALUE  Load PRES Value [ -10 ] > OK 

3. Confirm the applied loads by obtaining listings and displaying load symbols; then save the 
database. 

• ANSYS Utility Menu  
• List > Loads > DOF Constraints > on All Keypoints > Close 

• List > Loads > Surface Loads > On All Lines > Close 
• PlotCtrls > Symbols > [/PBC] > OK 

4. Initiate the solution 
 
• ANSYS Main Menu 
•Solution > -Solve- Current LS 
 
 
Postprocessing 
 
Review the results using the general postprocessor (POST1). We will view a deformed shape and the 
stress distribution. 

• ANSYS main Menu 
• General Postproc > Plot Results > Deformed Shape > KUND > Def + Undeformed > OK 
• General Postproc > Plot Results > -Contour Plot-  Nodal Solu... 

> Contour Nodal Solution Data > [Stress] > [X-direction SX] > OK 
• General Postproc > Plot Results > -Contour Plot-  Nodal Solu... 

> Contour Nodal Solution Data > [Stress] > [Y-direction SY] > OK 
• General Postproc > Plot Results > -Contour Plot-  Nodal Solu... 

> Contour Nodal Solution Data > [Stress] > [XY-shear SXY] > OK 
• General Postproc > Plot Results > -Contour Plot-  Nodal Solu... 

> Contour Nodal Solution Data > [Stress] > [von Mises SEQV] > OK 
 
The Von Mises, or equivalent stress (output quantity SEQV) is a measure of the stress intensity. It is 
computed as 
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Exit the program 
 
• ANSYS Toolbar>QUIT>SAVE Everything>OK 
 
 



 
Lab Report 
 
Submit the following plots as part of your lab report 
(1). The finite element mesh 
(2). Deformed shape 
(3). Contour plots of the direct stress yx σσ ,  and shear stress xyσ  
(4). Contour plot of the von Mises stress 



Ansys Lab — 2D Stress Analysis 

Purpose 

• Gain familiarity with 2D stress analysis 
• Learn to assess the accuracy of the analysis 

Lab exercise 

Consider stress analysis of a right-angle bracket with a 0.5 inch thickness. The bracket is 
constrained around the circumference of the upper left hole and has a concentrated load applied 
on the lower right hole as indicated in the figure below. The material is A36 steel with a Young's 
modulus of 30 x 106 psi and Poisson's ratio of 0.27. The bracket is analyzed using plane stress 
theory. 

 

1. Initial Setup 
 
1.1 Job name 
 
• Enter ANSYS from the launcher. 
• Type Bracket in the Initial jobname entry field of the dialog box. 
• Pick Run to apply the information. 

1.2 Set up the graphics area. 
 
• ANSYS Utility Menu 
• WP Settings >  Grid and Triad 

Snap Incr[ 0.2 ] 
Spacing[ 0.2 ] 
Minimum[ -4 ] 
Maximum[ 4 ] 

•Workplane > Display Working Plane 
•PlotCtrls >  View Settings > Magnification > DVAL User Specified [ 4.4 ] 



 

2. Preprocessing 

2.1. Begin solid modeling by creating two rectangles, 8 x 2 and 2 x 3, to form an L-shape. 
 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas- Rectangle > By 2 Corners  

[ WP = (-4, 1) ] 

[ WP = (4, -1) ] 

(Move the cursor to the right and down. Notice that the dimensions of the expanding 
rectangle are shown on the screen. Now, hold down the left mouse button and pick next 
point (4, -1).) 

[ WP = (2, -1) ] 

[ WP = (4, -4) ] 
> OK 

2.2. Create a circle at each end of the L-shape 
 
Create a circle at each end of the L-shape 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas- Circle > Solid Circle  

[ WP = (-4, 0) ] 

[ r = 1 ] 

(Notice that, as you move the cursor away from the centerpoint, a "rubber banding" circle 
appears and the radius is displayed. Move the mouse until r=1 is displayed, than click 
with the left mouse button.) 

[ WP = (3, -4) ] 

[ r = 1 ] 
> OK 

2.3. Use a Boolean operation to add the four areas to form one continuous piece (i.e., one 
area). 
 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Operate 



-Booleans- Add > Areas > Pick all  

2.4. Create 0.4 radius circle at each end of the L-shaped and subtract them from the main 
area to form the bolt holes. 
 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas-  Circle > Solid Circle 

[ wp = (-4, 0)]   

[r = 0.4 ]  

[ wp = ( 3, -4 )]   

[r = 0.4 ]  
> OK 

• Preprocessor > -Modeling- Operate 
-Booleans- Subtract > Areas 

[L-Shaped area ] 

(Pick the large L-shaped area as the base area from which to subtract.) 

 

("Apply" picking) 

[Left bolt hole circle] 

[Right bolt hole circle] 
> OK 

• ANSYS Toolbar > SAVE_DB 

2.5. Create a fillet at the inside corner of the bracket. 
 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Lines- Line fillet 

[Bottom line of left rectangle, marked A in the figure.]  

[Left line of square, marked B in the figure.]  

 

A
B

 
> OK 
> RAD [ 0.4 ] > OK 



• ANSYS Utility Menu > PlotCtrls > Pan, Zoom, Rotate...> ZOOM 

[Near the fillet line.] 

(Pick two points to define the zoom window, one at the center and one at the outer edge.) 

[At a point where the fillet line is totally enclosed by the zoom box.] 
• ANSYS Utility Menu > Plot  > Lines 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Create 

-Areas- Arbitrary > By Lines 
(An area can be created in the region of the line fillet by picking the lines which bound it.) 

[Fillet line marked A in the figure.] 

[Line marked B in the figure.] 

[Line marked C in the figure.]   

A

B

C
 

> OK 
• ANSYS Utility Menu > PlotCtrls > Pan, Zoom, Rotate...> Back Up > Close 
• ANSYS Main Menu 
• Preprocessor > -Modeling- Operate 

-Booleans- Add > Areas > Pick All > OK 
• ANSYS Toolbar > SAVE_DB 

2.6. Define the element type (PLANE42, the 2-D,  4 node, structural solid, bracket thickness, 
and material properties. 
• ANSYS Main Menu 
• Preprocessor > Element Type >Add/Edit/Delete>Add 

Structural Solid> [ Quad 4node 42 ]  
Options > PLANE42 element type options > k3 [ Plane strs w/thk ] > OK > Close 

(The Options button accesses options related to the selected element type. For the PLANE42 
element, we need to change the K3 option from "plane stress" to "plane stress with thickness.") 
• Preprocessor > real Constants >Add/Edit/Delet >Add..THK [0.5] > OK > Close 

 
• Preprocessor > Material Props > Material Model > Structural > Linear >Elastic >Isotropic> EX 
[ 30e6 ] PRXY [ 0.27 ] > OK > Material > Exit 

 
• ANSYS Toolbar > SAVE_DB 

2.7. Specify an element size and mesh the solid model. 
• ANSYS Main Menu 
• Preprocessor > -Meshing- Size Control 

-ManualSize- > -Global- Size > SIZE [ 0.5 ] > OK 
• Preprocessor > -Meshing- Mesh 

-Areas-  Free > Pick ALL 
• ANSYS Toolbar > SAVE_DB 



 
3. Solution 

3.1. Apply displacement constraints around the left hole and a prescribed displacement at 
the bottom of the right hole. It is an advantageous to apply the boundary conditions (loads) on 
the solid model rather than the nodes and elements. If the mesh density or element type is 
changed, there is no need to redefine the boundary conditions.  In this example, the boundary 
conditions (loads) will be applied to the solid model, more specifically, to keypoints.  

• ANSYS Utility Menu  
• PlotCtrls > Numbering > Plot Numbering Controls > KP > On > OK  
• Plot > Lines 
• ANSYS Main Menu 

• Solution > -Define Loads- Apply 
-Structural-  Displacements > On Keypoints 

[The four keypoints around the left hole.] 

 

("Apply" picking) 
• Apply U, ROT, on KPs > Lab2 [ All DOF ] > KEXPND > Yes > OK 
• Solution > -Loads- Apply 
-Structural- Displacement > On Keypoints  

[The four keypoints around the right hole.] 

 

("Apply" picking) 
• Apply U, ROT, on KPs > Lab2 [ UY ] >>VALUE[-0.1]> KEXPND > Yes > OK 

 

3.2. Confirm the applied loads by obtaining listings and displaying load symbols; then save 
the database. 

• ANSYS Utility Menu  
• List > Loads > DOF Constraints > On All Keypoints > Close 

• List > Loads > Force > On All Keypoints > Close 
• PlotCtrls > Symbols > [/PBC] > Applied B.C.'s > OK 

3.3. Initiate the solution 
 
• ANSYS Main Menu 
•Solution > -Solve- Current LS > OK 
 
 
 
 
 
 
 



4. Post-process 
 
4.1. Review the results using the general postprocessor (POST1).  
We will view a deformed shape plot and a plot of stresses in the global Cartesian X direction. 

• ANSYS main Menu 
• General Postproc > Plot Results 

Deformed Shape > KUND > Def + Undef edge  > OK 
• ANSYS Utility Menu  
• Plot > Results > Contour Plot > Nodal Solution > Contour Nodal Solution Data  

> [ Stress ] > [von Mises SEQV] > OK       ! von Mises stress 
 
Note: The von Mises or equivalent stress σe (output quantity SEQV) is computed as: 

σe ={
1
2

[(σ1− σ2 )2 + (σ2 − σ3)2 + (σ3 − σ1)2 ]}

1
2

 

where σ1, σ2 , σ3  are principle stresses(output quantities S1, S2 and S3) 

4.2. Obtain the total reaction forces at the two bolt holes 

• ANSYS Utility Menu  
• Selection>Entities… 

> [Nodes]> [By NUM/Pick]> [From Full]>OK 

> [Pick all the nodes on the upper-left bolt hole]>OK 
• ANSYS main Menu 
• General Postproc > List Results>Reaction Solutions > PRRSOL[All Items]>OK 

• ANSYS Utility Menu  
• Selection>Entities… 

> [Nodes]> [By NUM/Pick]> [From Full]>OK 

> [Pick all the nodes on the lower-right bolt hole]>OK 
• ANSYS main Menu 
• General Postproc > List Results>Reaction Solutions > PRRSOL[All Items]>OK 

• ANSYS Utility Menu  
• Selection>Entities>Select All>OK 

> [Pick All] 

5-Printing  von Mises Plot  & Deformed Shape. 
• ANSYS Utility Menu  
• PlotCtls > Style > Background > Display Picture Background 
• PlotCtls > Capture Image > File > Print > Print to > [Printer Name] > OK 

 

6. Save the database and quit ANSYS  
• ANSYS Toolbar > QUIT > Save Everything > OK  



 
Lab Problems 
 
 

1. Re-analyze the same problem using a finer mesh of global size [0.1]. Use mesh 
refinement at places of stress concentration. Mesh refinement can be invoked from the 
menu path 

 • Preprocessor > -Meshing > Modify Mesh > Refine at > Element 
 Click on the element where finer mesh is to be applied.  

 
2. Compare the solutions on maximum vertical displacement and the maximum von Mises 

stress. Comments on the results. Submit the following plots for each analysis 
 

1. The finite element mesh 
2. The deformed shape 
3. von Mises contour plot 

 
 

Tips 
 
The lab problem requires creating a new mesh even though the underlying solid model is the 
same. The easiest way to create the new mesh is to read the model from the database – make 
sure to rename the jobname afterwards - and then to delete the existing mesh, and mesh 
again. If the boundary data are applied on the solid model (which is the case in this lab), then 
there is no need to input the boundary condition again.  

 


