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ANSYS EXERCISE 
Modal Analysis of a Spring-Mass System 

     
 
In this exercise, you will solve for the natural frequencies and mode shapes of the 2-DOF system 
shown below.  Step-by-step instructions are provided beginning on the following page.   
 
 
 
Notes: ANSYS has an option that will allow for the masses to be modeled as point masses.  
Using this option, no dimensions or material properties would be necessary for the masses.  
However, so that the mode shapes are easier to understand when they are animated, in this case, 
the masses will be modeled as blocks, 1 m x 1 m, with unit thickness.  So, they have a volume of 
1 m3.  The densities will be specified to produce the correct masses.  Also, the free lengths of the 
springs are irrelevant in this analysis, as only the stiffnesses matter.  But, they will both be 
assumed to have a length of 5 m.    
   

 
 
 

 
 
 
 
 
 
 
 
 
The steps that will be followed, after launching ANSYS, are: 
 

M= 2 kg

x1 x2

K= 5 N/m K= 20 N/m
M= 1 kg
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Preprocessing: 
1. Change jobname. 
2. Define element types (#1 - Solid42 element;  #2 - Combin14 element). 
3. Specify material properties for the masses. 
4. Specify real constants for the springs. (Spring stiffnesses.) 
5. Create rectangles (actually, “squares”) 
6. Specify mesh controls for the masses. 
7. Mesh the areas. 
8. Create a node at the wall. 
9. Create the spring elements. 
10. Apply constraints. 
11. Make rigid body constraints for each mass. 
 
Solution: 
12. Specify analysis type and options.  
13. Solve. 
 
Postprocessing: 
14. List the natural frequencies. 
15. Animate the mode shapes.  
16. List the mode shapes. 
 
Exit 
17. Exit the ANSYS program, saving all data. 
_____________________________________________________________________________ 
 
 
Launching ANSYS: 
 

It is probably best to save your work on a Zip Disk in the computer IOMEGA Zip Drive.  
On any machine in the computer lab (on the first floor of Crounse Hall), insert a Zip Disk in the 
drive.  Then, simply click on the ANSYS icon on the Windows Desktop.  The ANSYS Launcher 
menu should appear.  It is shown at the top of the next page.  The only input you will likely need 
on this menu is specification of the Zip Drive as your “Working Directory”.  If you don’t have a 
Zip Disk, or if you prefer to work on the computer hard drive instead, then specify any directory 
(or, “Folder”) as your working directory.  To browse and find the desired working directory, 
click on the button with the three dots to the far right on the Launcher Menu on the line that says 
“Working Directory”.  Once the working directory is specified, click on “Run” at the bottom of 
the Launcher Menu. 
 

The ANSYS menus should open up.  You will see a Main Menu, illustrated on the 
following page, and a large black graphics window.  You are now ready to begin creating the 
model and performing the analysis. 
 
 
ANSYS Launcher Menu: 
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ANSYS Main Menu: 
 
 
 
 
 
 
 
 
 
 
 
 
Note:   Most of the required tasks are performed using menu picks from the ANSYS Graphical 
User Interface, as specified in italics in the step-by-step instructions below.  It is sometimes more 
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convenient, however, to enter certain commands directly at the command line.  The command 
line is seen on the screen as: 
 

 
 
The method of direct command line entry is used in some cases in this exercise, whenever this 
method is more convenient than using menu picks.   

 
Often, as an alternative, an input file, known as a “batch file”, is created, which is simply 

an ASCII text file containing a string of ANSYS commands in the appropriate order.  ANSYS 
can read in this file as if it were a program, and perform the analysis in “batch mode”, without 
ever opening up the Graphical User Interface.  The batch file option is not covered in this 
exercise.     
 
****IMPORTANT***:  AS YOU WORK THROUGH THIS EXERCISE, WITHIN 
ANSYS, ON THE ANSYS TOOLBAR (UPPER RIGHT), CLICK ON “SAVE_DB” 
OFTEN!!!  THIS TOOLBAR APPEARS AS: 

 
 

At any point, if you want to resume from the previous time the model was saved, simply 
click on “RESUM_DB” on this same Toolbar.  Any information entered since the last save will 
be lost, but this is a nice feature in the event that you make an input mistake, and are unsure of 
how to correct it.   

 
There are a number of ways to model a system and perform an analysis in ANSYS.  The 

steps below present only one method. 
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Preprocessing: 
 
1. Change jobname.  On the Utility Menu across the very top of the screen, select:  
       File -> Change Jobname 
 Enter “modalsys1”, and click on “OK”.    
 
2. Define element types: Preprocessor -> Element Type -> Add/Edit/Delete 

Click on “Add”.   The “Library of Element Types” box appears, as shown.  Scroll down 
to highlight “Solid”, and “Quad 4node 42” as shown. Click on “APPLY”.   

 
 

 
 

Now, scroll down to highlight “Combination” and “Spring-Damper 14” as shown, then 
click on “OK” and “Close”.   

 

 
 
3. Specify material properties for the masses:  

 
Preprocessor -> Material Props -> -Constant- Isotropic   

 
On the box, shown on the next page, enter “1” in the “EX” input field (EX is the modulus 
of elasticity), and enter “2” in the “DENS” input field, as shown, then click on “APPLY”.  
Note that an arbitrary value was entered for EX, because we will couple all DOF on each 
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mass so that they move as rigid bodies.  So, the modulus of elasticity for each mass, in 
this particular analysis, is irrelevant.  However, we chose the density to produce a block 
of mass=2 kg.  Our block will have a volume of 1 m3.   
 After entering the input, click on “APPLY”.  The “Isotropic Materials Box” 
should be showing on the screen, and at this point, the material number is still set to “1”.  
Change the material number to “2”, and click on “OK”.  The material properties box, like 
that below, re-opens.  Again, enter “1” for EX, but this time, enter “1” for density.   Click 
on “OK”. 
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4. Specify real constants for the springs 
 
 

Preprocessor -> Real Constants -> Add/Edit/Delete -> Add 
 
The box below will open.  Be sure that “Type 2 COMBIN14” is highlighted, and click on 
“OK” 

 
 
 
For real constant set “1”, choose “K=5”, as shown below.  Leave the other fields blank, 
and click on “Apply”.   Then, change the Set Number to “2”, and enter a value of “20” 
for K, then click on “OK”, then “Close”.   Note that, for this model, we will not need any 
real constants for the PLANE42 elements.  We are using the option that assumes a unit 
thickness for these elements.     
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5. Create rectangles: 

  
   Preprocessor -> Modeling- Create -> -Areas- Rectangle -> By Dimensions 
 
Fill in (X1,X2)=(5,6), and (Y1,Y2)=(0,1), as shown below.  Then, click on “Apply”.  
 
 

 
 
Create the block for the other mass by filling in (X1,X2)=(11,12), and (Y1,Y2)=(0,1), 
and then click “OK”.   
 
 
 

6. Specify mesh controls for the masses.  
 
 As stated previously, this model involves creating blocks to model the masses, but 
they are going to be set so that each mass moves as a rigid body.  In general, in finite 
element modeling, the finer the mesh, the more accurate the results.  However, in this 
case, the mesh density for each separate mass is irrelevant.  So, each mass will be 
modeled as a single element.  Choose: 
 

Preprocessor -> -Meshing- Size Cntrls -> -Lines- Picked Lines 
 
This opens up a Picking Menu, as shown on the next page. This box would allow for 
picking individual lines.  But, in this case, we want a single element division for every 
line.  So, in the Picking Menu, choose “Pick All”.  This opens up an “Element Sizes”  
box, also shown on the next page.   Input “1” for “NDIV” , as shown, and click on “OK”.  
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7. Mesh the areas. 
 
First, in case the areas are not currently plotted, along the top toolbar: 
 

 
 
Choose: Plot -> Areas 
 
Then, choose: 
 

Preprocessor -> -Meshing- Mesh -> -Areas- Mapped -> 3 or 4 sided 
 

A Picking Menu opens (which has the label “Mesh Areas” at the top of the menu). 
Click on the block on the left (which will be the 2 kg mass).  It should highlight.  Then, 
click on “OK” in the Picking Menu.    Since we are only creating a single element in each 
block, at this point, a plot of the elements looks just like a plot of the areas.  But, there are 
now nodes at the corners of the left-hand block, and this block contains a single 
PLANE42 finite element.  Probably, an element plot has appeared showing only the 
single meshed element.   

Re-plot the areas, as done above, by choosing, on the top toolbar: Plot -> Areas   
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Now, before meshing the second area, the material number needs to be changed to 
number 2, because the density of the two masses is different, and we defined different 
materials to account for this.  To do this, use the path: 
 
Preprocessor -> -Modeling- Create -> Elements -> Elem Attributes 
 
 
The box below opens.  Change the [MAT] entry to “2”, as shown.  No other changes are 
needed at this time, so click “OK”.  
 

 
 
Now, to mesh the second mass, choose: 
 

Preprocessor -> -Meshing- Mesh -> -Areas- Mapped -> 3 or 4 sided 
 

A Picking Menu opens (which has the label “Mesh Areas” at the top of the menu). 
Click on the block on the right (which will be the 1 kg mass).  It should highlight.  Then, 
click on “OK” in the Picking Menu.    
 
 

8. Create a node at the wall: 
 

Preprocessor –> Create -> Nodes -> In Active CS 
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In the box that opens, as shown on the next page, there is no input required for this case.  
This is only because we are going to create the node at (X,Y,Z)=(0,0,0).  Also, we do not 
need a node number, because ANSYS will use the lowest available node number if we 
leave the node number field blank.  Just click on “OK”.  
 

 
It is probably a good idea now to turn off the display of the X-Y-Z triad, because it 
covers up the node at the wall in the plots.  Along the top toolbar: 
 

 
 

Choose: PltCtrls -> Window Controls -> Window Options. 
 

 In the box that opens, for [/TRIAD], select “Not shown”, then click on “OK”.    
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Now, it is probably a good idea to turn the node numbers on.  They may be showing 
already at this time, but to make sure they are, on the top toolbar: 
 

 
 
Back on the top toolbar, again choose “PlotCtrls”, then “Numbering”, and the box below 
opens.  Toggle the “Node” option from “Off” to “On” by clicking on the box.  You 
should see a check mark appear in the box, as shown below. 
 
 

 
 
 
Although nodes are probably already plotted now, to make sure, on the top toolbar, 
choose Plot -> Nodes. 
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9. Create the spring elements.  

 
First, the element type needs to be changed to type 2, which is the element type number 
we used in defining the Combin14 (spring) element type.  To do this, use the path: 
 
Preprocessor -> -Modeling- Create -> Elements -> Elem Attributes 
 
 
The box below opens.  Change the [TYPE] entry to “2    COMBIN14” as shown.  No 
other changes are needed at this time, so click “OK”.  
 
 

 
 
 
 
Now, to create the first spring element, choose: 
 
Preprocessor -> -Modeling- Create -> Elements -> -Auto Numbered – Thru Nodes 
 
A picking menu opens.  It should be that the numbered nodes are plotted on screen at this 
time.  Node number 9 should be the node at the wall, and node number 1 should be the 
node at the bottom left-hand side of the 2 kg mass.   
 
Click once, with the left mouse button, on node 9, then click again, once, on node 1.  
Then, in the picking menu, click on “OK”.   
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Now, before creating the other spring, the real constant set number needs to be changed 
to set 2, because the spring constant is different for the two springs. To do this, use the 
path: 
 
Preprocessor -> -Modeling- Create -> Elements -> Elem Attributes 
 
In the box that opens, change the [REAL] entry to “2”.  No other changes are needed at 
this time, so click “OK”.  Then, choose: 
 
Preprocessor -> -Modeling- Create -> Elements -> -Auto Numbered – Thru Nodes 
 
A picking menu opens.   Node number 2 should be the node at the bottom-right corner of 
the left-hand mass, and node 5 should be the node at the bottom-left corner of the right-
hand mass.  Click once, with the left mouse button, on node 2, then click again, once, on 
node 5.  Then, in the picking menu, click on “OK”.   
 
Plot the elements, by choosing, on the top toolbar: Plot-> Elements 
 
 

10. Apply constraints. 
 
It is assumed that only X-direction motion is allowed.  So, the Y and Z direction motion 
must be constrained to zero at all nodes.   
 
Preprocessor -> Loads -> Apply -> Displacement -> On Nodes 

 
A picking menu applies.  We want this constraint to apply to all nodes in the model.  So, 
in the picking menu, choose “Pick All”.   Another box opens.  Be sure to Un-highlight 
“All DOF”, by clicking on it.  Then, highlight “UY” and “UZ” by clicking on these 
labels, as shown, and then click on “Apply”. 
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The picking menu should remain open.  Click on the node at the wall (this should be node 
number 9), and then click on “OK” in the Picking Menu.  This node should not move in 
any direction.  So, choose, in the box that opens, as shown on the previous page, click on 
“All DOF”, and then click on “OK”.  
 
 
 

11. Make rigid body constraints for each mass. 
 
Each mass is supposed to move as a rigid body.  We can produce this effect by coupling 
all nodes on each mass so that they move together.  To do this, choose: 
 
Preprocessor -> Coupling / Ceqn -> Couple DOFs 

 
 

A picking menu opens.  Click on nodes 1-2-3-4, to highlight all four nodes that define the 
left-hand mass.  Then, in the Picking Menu, click on “Apply”.  A box, as shown below, 
opens.  Enter “1” for “NSET”, as shown, and leave the label “UX” for “Lab”.  Then, 
click on “Apply”. 

 
 
The picking menu should re-open.  Click on nodes 5-6-7-8, to highlight all four nodes 
that define the right-hand mass.  Then, in the Picking Menu, click on “OK”.  A box, as 
shown above, re-opens.  This time, Enter “2” for “NSET”, and again leave the label 
“UX” for “Lab”.  Then, click on “OK”. 
 
 

12. Specify analysis type and options. 
 
Return to the main ANSYS Menu, and choose: 
 
Solution -> -Analysis Type- New Analysis 
 
In the box that opens, select “Modal” and click on “OK”.   
 
Then, select: Solution -> Analysis Options 
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The box below opens.  Enter “2” for “No. of modes to extract” and “2” for “NMODE  
No. of modes to expand”.   Choose “OK”, and the box at bottom opens.  Enter “1000” for 
“FREQE”, as shown, then click on “OK”.  
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13. Solve 
 
Choose: Solution -> -Solve- Current LS 
 
A green box will appear.  Just click on “OK” in the box.  You should then, very quickly, 
get a yellow box, with the note “Solution is done!”.  You can close this box. 
 

14. List Natural Frequencies 
 
Return to the ANSYS Main Menu, and choose: 
 
General Postproc -> Results Summary 
 
You should get a box listing two natural frequencies.  One is for “Set 1” and the other is 
for “Set 2”.  Set 1 is the set of results corresponding to Mode 1, and Set 2 is the set of 
results corresponding to Mode 2.  Note the natural frequencies (these are listed in units of 
“Hz”), then close the listing box. 
 

15. Animate the Mode Shapes 
 
Choose:  General Postproc -> -Read Results- First Set 

 
 Then, on the top toolbar, choose: PlotCtrls -> Animate -> Mode Shape 
 

In the box that opens, you may want to change “No. of frames to create” to some higher 
number than the default of 10.  For instance, you may enter 20.  Also, you may want to 
change the time delay to some smaller number than the default of 0.5.  For instance, you 
may enter 0.2.  Then, in that box, click on “OK”.  
 
It may take a couple of minutes for the animation to begin, but eventually, you should 
see, on the screen, the expected motion corresponding to the first mode shape.  At any 
time, you can click on “Close” in the blue “Animation Controller” box to end the 
animation.  
 
To animate the second mode shape, choose: 
 
 General Postproc -> -Read Results- Next Set 
 
Again, back on the top toolbar, choose: PlotCtrls -> Animate -> Mode Shape 
 
Repeat the procedure outlined above, and you should see the animation of the second 
mode shape.   
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16. List the Mode Shapes 
 
Choose:  General Postproc -> -Read Results- First Set 
 
Then, choose:  General Postproc -> List Results -> Nodal Solution 
 
 
In the box that opens, as shown below, keep the defaults by just clicking on “OK”.   
 

 
 
A listing of the relative displacements for each node for mode 1 is shown, and the 
frequency for the mode is also shown.   
 
You can get a hard copy of the information in this box by clicking, in this listing box:  
File -> Print.  It should also be possible to save this information to a file using the 
option, File -> Save As.  However, this “Save As” option does not appear to be working 
properly in the current ANSYS version.  Another option, however, is to use the mouse to 
block this information in (hold down left mouse button and drag to highlight the text and 
numbers), then, on the keyboard, simultaneously hit the Control Key, and the letter “c” 
(Ctrl-C), then, open up either “Notepad”, or some word processing program, such as 
Microsoft Word.  In the program of your choosing, choose “Paste”, or else use “Ctrl-V”, 
to insert the text copied from the listing box.   If desired, you may close the listing box to 
get it out of the way.  To do this, in that listing box, choose: File -> Close. 
 
Now, list the second mode shape in a similar way.  First, choose:  

  

General Postproc -> -Read Results- Next Set 
 

Then, as above, choose:  General Postproc -> List Results -> Nodal Solution 
 
In the box that opens, choose “OK”.  You can again get either a hard copy print-out of the 
information, or save it in a file, as outlined above.   
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17. Exit the ANSYS program, saving all data.   
 

On the ANSYS Toolbar, shown below, choose:  
 

Quit ->Save Everything -> OK 
 
 

 
 
 

 
 
 
 
 

To recall the model and solution at a later date, assuming you have deleted no 
files, simply re-launch ANSYS, specify the same working directory as before, re-issue 
the same jobname as used in Step 1 of these instructions, and then click on 
“RESUME_DB” on the ANSYS Toolbar shown above.   

 
To see the resumed model in the graphics window, you may then need to click on “Plot” 
on the top Utility Menu:  

 

 
 

Then, choose either “Elements”, “Nodes”, or “Areas”, depending on which entities you 
wish to plot.  

 
 
 
 
 
 
 
 


